Testing Cheats (Solved!)
#1 02-12-2015 
This is the first time I've run across this so I must ask:

Does anyone know why having testing cheats enabled would cause any lot to NOT load?

I turned the cheats on and the lot my objects were on wouldn't load. So I took the objects I wanted to "test" out and tried again. The lot still wouldn't load. Thinking it was just that lot I restarted my game and tried a different lot (with testing cheats on) - that lot wouldn't load. Thinking the objects I cloned to make my new objects might be a problem, I took those out and tried again. None of the lots in my hood will load with the testing cheats enabled.

I'm not really that worried about my new meshes causing errors. During my fine-tuning of them I noticed the action for one of them would drop from the queue but had an idea why and fixed that. My objects work just like they're meant to - in my game at least.

edit to add: I tried Googling, the only thing I found that's remotely close to my issue is an old topic at TSR where lots wouldn't load with testing cheats OFF.
(This post was last modified: 03-12-2015 09:42 PM by mustluvcatz.)

#2 02-12-2015 
If a lot will not load with testing cheats enabled, I'm guessing that some mod or object causes an error. With cheats off, the error would be skipped. But with cheats on, the game will try to report it. If that fails, the game simply gives up.

Obviously, this is not some tiny error if the game refuses to load the lot. I think you may need to run the 50/50 dance to find the offending item.

#3 02-12-2015 
That's what I suspected but was trying to avoid, lol. *sigh* Thanks BO! At least my testing game isn't my full game.. that would take forever the 50/50 way. Like I said, I'm sure it's not my new meshes causing this since lots won't load with them removed from my downloads folder. But I'd like to be sure of that so off to play 50/50 I go! Smile

#4 03-12-2015 
I've just discovered there's a log file called "OETreeDelete.xls" that gets generated when you turn on testingcheats.... according to MATY. I discovered this by googling the filename because it's currently preventing me from making a backup - computer keeps getting stuck while trying to copy that specific file. I wonder if that file could have anything to do with your lot loading problem? According to MATY it's safe to delete so maybe worth a shot.

#5 03-12-2015 
Interesting idea. Since all files in the Logs folder are indeed safe to delete - and thus there's no risk of exacerbating the problem -, I'd encourage MLC to test that. It might indeed fix the issue.

#6 03-12-2015 
Hmm. Interesting indeed. I've actually looked at one of those OETreeDelete files in the past. The one that's in the Logs folder now won't even open, doesn't matter if I open Excel first or click on the log file first. Not only that - I'm trying to delete it now and it's just sitting there "Preparing to recycle", there is no reason it shouldn't delete since there is nothing using it. (TaskManager is always open and I will kill programs without mercy.) What the heck?!

#7 03-12-2015 
Damn, so THAT is the problem file. Have you tried rebooting the machine? Maybe after that, it will delete the file.

#8 03-12-2015 
I haven't tried that yet but only because I went to sleep. Smile The file may (should actually, but you never know) be able to be deleted using cmd prompt.. I'll be trying that soon-ish.

BUT if I manage to get it deleted, won't it just pop up again next time I enable cheats and cause the same problem? If it *is* the file causing problems a way to prevent it from being created in the first place would be ideal.. I'd think.

This file really has me wondering - won't delete the "normal" way, can't look at the properties, won't open with any program, Avast hangs if I try to scan it. I keep thinking it's a virus of some sort but I know I've seen that file in the logs folder many times and have even opened one with Excel in the past. I think to be safe I'm going to spend the day letting MalwareBytes and Avast do their thing after I get rid of this file.

#9 03-12-2015 
If I may ask, @mustluvcatz, does the windows explorer tell you how large this OETreeDelete.xls file is? Can't it be opened with a text editor? My editor (UltraEdit) has no trouble reading .xls files.

This file is normally created during *every* play session, and not during any other event. Enabling/Disabling testingcheats should have nothing to do with it (I think). Also, I cannot imagine that it is anything you did that caused the file to misbehave. But since it *is* an xls file, it might have been touched by some malware program that inserts a virus into spreadsheets in order to trigger some reaction from Excell or similar programs.

So, yes, maybe letting your scanners have a field day is not such a bad idea.

#10 03-12-2015 
It's 98kb. I can't open it with anything. And, as it turns out, I can't delete it with cmd prompt either. The file path is right, the command seems to run but the file is still there. I can't do ANYTHING with that file - just right- clicking on that one causes the explorer window to stop responding altogether.

I decided to check one of my other games (I have 3 games set up) Logs - the OETreeDelete in that one would delete just fine if I wanted to delete it. My bright idea was to try copying that one to the other folder, hoping it would overwrite it and allow me to delete it. Did it work? Nope. I'm tempted to load that other game and see if testing cheats will work BUT I think I should resist that until I run the scans.. which I'm going to do right now. Ugh. If it comes down to it I may just have to get rid of that game and start a new testing game.


Sorry, that is a members only option